BarAPI——强大的BOSS血条公告前置插件

联机侠

这个插件本身没有任何作用,它只是作为一个前置插件或者用于插件开发。

u=3040106798,554023567&fm=23&gp=0 BarAPI提供了一组显示BOSS血条的API,可以让插件开发者更方便地在自己的插件中使用BOSS血条。
所以有一些插件可能会用到BarAPI作为前置插件

配置
BarAPI.setMessage(Player player, String message)
BarAPI.setMessage(Player player, String message, float percent)
BarAPI.setMessage(final Player player, String message, int seconds)
BarAPI.hasBar(Player player)
BarAPI.removeBar(Player player)
BarAPI.setHealth(Player player, float percent)

纠正:
BarAPI.setHealth(Player player, float percent)和其他的都不是权限,这个是给开发者用的API代码
并且这个API是在屏幕上显示Boss血条来做公告这样的插件,不是简单的发送消息
.

其他

· 不能超过64个字符的消息。
如果超过上限,BarAPI将自动削减到64个字符,以防止客户端崩溃。
这是一个客户端限制,不能更改。
· 该插件的源码可见原帖地址
·作者声称在下一个版本将会修复BUG、
· 如果你想知道更详细的版本的细节更新 请自行到原贴地址!


一些需要BarAPI做前置的插件

  • WelcomeBar
  • Parkour
  • QuickSupport
  • BossBroadcast
  • BossMessage血条公告
  • PvPGames Automated
  • BossEventScheduler
  • Infernal Mobs
  • MythicMobs
  • MultiKill
  • PlayerBoss
  • BossAds
  • Item Lore Stats
  • BossBarPro
  • VIPLobby
  • Battle Of Blocks
  • BossBroadcaster
  • SilkSpawners
  • BarJoin
  • JoinGlobalMessages

 

配置文件

<repositories>        <repository>                <id>confuser-repo</id>                <url>http://ci.frostcast.net/plugin/repository/everything</url>        </repository></repositories><dependencies>        <dependency>                <groupId>me.confuser</groupId>                <artifactId>BarAPI</artifactId>                <version>3.0</version>        </dependency></dependencies>

原帖地址

适用版本:1.7.10-1.10

文件下载

联机侠
联机侠

发表评论

您必须 登录 才能发表留言!